Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 19, 2026 - 08:00 CET
Scheduled
Due to issues with the line stability in Quévy, our supplier will monitor and fix the line in the upcoming week. As there is a backup line, the disruptions should barely be noticable.
Posted Mar 18, 2026 - 17:26 CET
This scheduled maintenance affected: Network & Telephony Services.